Python version in NKEE 5.2.1?

Poster Content
nk4um User
Posts: 6
October 31, 2016 16:27

Thanks very much, Peter. We're just starting with our Python development, so we can probably wait for the official release of 6.1.1...looking forward to it!

Best,

Gary

Like · Post Reply
nk4um Moderator
Posts: 898
October 28, 2016 07:25

Hi Gary - sorry for the confusion. We have recently put some work into refreshing the Python support. For a long time Jython was not quite fully equivalent to C-Python wrt libraries etc. However you can now use full Python 2.7.0 with the complete library.

We are very close to the general launch of NKEE-6.1.1 but the updated repository is already available and so you can get the updated Python modules. Please follow these steps (and keep this under your hat whilst we complete final production testing)...

Important: Make sure you're running Java 8 before doing the following. Java 7 is EOL and NKEE-6.1.1 now requires Java 8.

  1. On NKEE-5.2.1 in Apposite synchronize and accept all updates
  2. In the Apposite -> Admin edit the repo path and change 5.2.1 to 6.1.1
  3. Test connection and Synchronize again
  4. Accept all updates
  5. You are now running NKEE 6.1.1 and Python will be full 2.7.0

When we announce the release this process will be automatic and 5.2.1 will smoothly update to 6.1.1

The core of 6.1.1 is no different to 5.2.1 (barring a few optimisations) the main changes are to the NKEE dev/ops tools and, as you need, refreshes to the auxilliary technology with 3rd party library dependencies.

Please let us know how you get on and if this is what you were looking for?

Cheers,

Peter

Like · Post Reply
nk4um User
Posts: 6
October 28, 2016 00:55Python version in NKEE 5.2.1?

Hi all,

I just tried doing some module development in Python (for the first time), and am a bit confused. The details on the lang-python and lang-python-lib Apposite packages indicate that Jython/Python 2.7 are being used, but lang-python-lib (version 2.6.1) is exposing res:/library/python/2.5.0/ rather than res:/library/python/2.7.0/, even though Apposite shows the following:

Can anyone offer clarification as to which version of Python/Jython is actually being used?

Thanks in advance, --Gary

Like · Post Reply